Souhrn topologií a konfiguračních příkazů konfigurace Border Gateway Protocol (BGP) II

Z MilataWiki

Přejít na: navigace, hledání


Příkladová topologie

Topologie sítě source in Dia
Topologie sítě source in Dia

Konfigurační příkazy

Konfigurace směrovače

Základní konfigurace směrovačů

(config)# hostname <name>
(config)# interface <typ> <num>
(config-if)# ip address <IP> <mask>
(config-if)# clockrate <clock>
(config-if)# no shutdown

Poznámka: clockrate se nastavuje pouze v případě, že se jedná o sériové rozhraní.

(config)# router ospf 1
(config-router)# network <IP_net> <wildcard> area 0
(config-router)# passive-interface fastethernet 0/0
(config-router)# default-information-originate always
# ping <IP_address>
# show cdp neighbors
# show ip interface brief 
# show ip route
# show ip ospf neighbor

Poznámka: významy jednotlivých příkazů již byly diskutována dříve v rámci předchozích cvičení. Zde jsou jen uvedeny jako možný nástroj pro ověření funkčnosti provedené konfigurace. Předpokládá se, že se uživatel v poskytnutém výpisu dokáže zorientovat.

Základní konfigurace protokolu BGP

(config)# router bgp <as_num>
(config-router)# network <ip_net> [mask <net_mask>]
(config-router)# neighbor <ip_nei_router> remote-as <as_num>
(config-router)# neighbor <ip_nei_router> update-source loopback <num>
(config-router)# neighbor <ip_nei_router> ebgp-multihop <hop_num>
# show ip route
# show ip bgp neighbor
# show ip bgp

Použití BGP atributů pro ovlivnění výchozího stavu směrování

Atribut Local preference

(config)# access-list 1 permit <IP address> <wildcard mask>
(config)# route-map <name> permit 10
(config-route-map)# match ip address 1
(config-route-map)# set local-preference <num>
(config)# route-map <name> permit 20
(config-router)# neighbor <ip_nei_router> route-map <name> in
# clear ip bgp *
# show ip bgp
# show ip route

Atribut MED (Multi-Exit Discriminator)

(config)# access-list 2 permit <IP address> <wildcard mask>
(config)# route-map <name> permit 10
(config-route-map)# match ip address 2
(config-route-map)# set metric <num>
(config)# route-map <name> permit 20
(config-router)# neighbor <ip_nei_router> route-map <name> out
# clear ip bgp *
# show ip bgp
# show ip route

Sumarizace BGP

(config)# router bgp <as_num>
(config-router)# aggregate-address <sum_addr> <sum_mask> summary-only
Osobní nástroje
výuka