Konfigurace a optimalizace protokolu BGP

Z MilataWiki

Přejít na: navigace, hledání

Podpůrný materiál k tutoriálu 4

Obsah

Síťová topologie

Topologie sítě source in Dia
Topologie sítě source in Dia

Konfigurační příkazy

Uvedené konfigurační příkazy se vztahují k zařízením vyráběných společnosti Cisco.

Základní konfigurace směrovače

Pojmenování směrovače a zákaz interpretace chybně napsaných příkazů jako doménových jmen.

(config)# hostname <name>
(config)# no ip domail lookup

Konfigurace rozhraní směrovačů

(config)# interface <type> <num>
(config-if)# ip address <ip> <mask>
(config-if)# clock rate <rate_in_bps>
(config-if)# no shutdown

Ověřování základní konfigurace

# show running-config
# show ip interface brief
# show ip route
# show cdp neighbors [detail]

Základní konfigurace protokolu BGP

Spuštění procesu BGP s odpovídajícím číslem autonomního systému, konfigurace sítí spravovaných protokolem BGP a vytvoření sousedských vazeb mezi BGP směrovači.

(config)# router bgp <as_num>
(config-router)# network <ip_net> [mask <net_mask>]
(config-router)# neighbor <ip_nei_router> remote-as <as_num>

Poznámka: položka as_num v příkazu konfigurace souseda slouží k identifikaci autonomního systému sousedního směrovače. Dále na jením základně je lokální směrovač schopen určit, o jaký typ relace se sousedem se jedná.

Ověření výsledků základní konfigurace BGP

# show ip route
# show ip bgp neighbor
# show ip bgp summary
# show ip bgp
# clear ip bgp *

Zanesení adres spojovacích linek do směrování

Konfigurace statického směrování adres spojovacích linek

(config)# ip route <ip_net> <mask> <next_hop_ip>

Optimalizace směrování v rámci autonomního systému

Výběr sítě pomocí access-list

(config)# access-list 1 permit <IP address> <wildcard mask>

Konfigurace route-map struktury, pomocí níž sítím vybraným access-list-em nastavíme hodnotu local-preference.

(config)# route-map <name> permit 10
(config-route-map)# match ip address 1
(config-route-map)# set local-preference <num>
(config)# route-map <name> permit 20

Poznámka: route-map struktura musí obsahovat kromě řádku, který specifikuje zacházení s cestami, pro něž nastavujeme hodnotu local-preference, ještě záznam pro zbylé sítě, které nejsou zmíněným záznamem ovlivněny.

Spojení vytvořené route-map struktury s konkrétním BGP sousedem.

(config-router)# neighbor <ip_nei_router> route-map <name> in

Ověření správnosti konfigurace včetně urychlení konvergence BGP protokolu (pouze pro laboratorní účely, způsobuje nestabilitu)

# clear ip bgp *
# show ip bgp
# show ip route

Ovlivňování směrování mimo lokální autonomní systém

Výběr sítě pomocí access-list

(config)# access-list 2 permit <IP address> <wildcard mask>

Konfigurace route-map struktury, pomocí níž sítím vybraným access-list-em nastavíme hodnotu MED (metric).

(config)# route-map <name> permit 10
(config-route-map)# match ip address 2
(config-route-map)# set metric <num>
(config)# route-map <name> permit 20

Spojení vytvořené route-map struktury s konkrétním BGP sousedem.

(config-router)# neighbor <ip_nei_router> route-map <name> out

Ověření správnosti konfigurace včetně urychlení konvergence BGP protokolu (pouze pro laboratorní účely, způsobuje nestabilitu)

# clear ip bgp *
# show ip bgp
# show ip route

Konfigurace a optimalizace protokolu BGP - ukázková konfigurace

Osobní nástroje
výuka